TOOLS

Chapter 7


Overview

If you've read the previous chapter, you know how to record and overdub Tracks. Now it's time to move to one of the most important aspects of Bars&Pipes Professional: Using Tools.

What is a Bars&Pipes Professional Tool? Technically, a Tool is device that sits in a Track's PipeLine and performs an operation on the MIDI events flowing through it. Some Tools are musical in nature and perform operations that are standard operations, like delay and quantize. But Tools can also organize the flow of the music by interconnecting PipeLines, help compose music by creating or changing notes, and even translate music events into other media, such as displayed pictures.

Tool Modules

Tools are special additions to Bars&Pipes Professional's main program. Each Tool is actually a separate module that Bars&Pipes Professional loads. This is a very important concept.

You can expand the capability of Bars&Pipes Professional by adding more Tools without upgrading Bars&Pipes Professional itself. And, you can remove unneeded Tools to save memory.

Once you've loaded a Tool, Bars&Pipes Professional automatically installs it each time. When you remove a Tool, Bars&Pipes Professional will no longer install it.

NOTE-> Sometimes, you might create a Song with a particular Tool in its PipeLines, save it, then remove the Tool at a later date. Great news! If Bars&Pipes Professional senses the Tool is missing, it reinstalls it automatically.

Multiple Usage Of Tools Once you've installed a Tool in Bars&Pipes Professional, you can use it in several different places at a time. Each time you drag a Tool out of the ToolBox, Bars&Pipes Professional makes a unique copy of the Tool. This way, you can setup each copy to behave differently.

Example:
Set one instance of an Echo Tool to create four echoes in Track 1, while setting a second Echo Tool in Track 2 to create only two echoes. Each Echo Tool is a unique copy of the original Echo Tool that Bars&Pipes Professional loaded when you installed it.


Tool Types

Tools fall into two primary categories: Music Tools and Multi-Media Tools. Within these categories, Tools are further classified as Input, Output, and Branching Tools. Input and Output Tools serve as the inputs and outputs of each Track's PipeLine, i.e., the MIDI In and MIDI Out Tools. Branching Tools connect PipeLines between Tracks. Combinations of Tools are called MacroTools.

Music Tools

Music Tools perform musical functions. The Quantize Tool (tightens the note timing,) CounterPoint Tool (creates a counter melody,) and Quick Patch Tool (sets up the MIDI instrument) are examples of Music Tools.

Multi-Media Tools

Multi-Media Tools, in conjunction with Bars&Pipes Professional's Media Madness window, control non-musical aspects of sequencing, including other hardware and software. The ANIMal Tool (plays animations,) Toasty Tool (controls the Video Toaster,) and Command Performance Tool (sends ARexx commands to other programs) are examples of Multi-Media Tools. Most of the Multi-Media Tools are also Output Tools. The Media Madness window controls Multi-Media Tools that are also Output Tools.

Macro Tools

MacroTools are a special category of Tools. MacroTools are combinations of regular Tools. Use MacroTools to create your own Tools by putting together individual Tools with the Create-A-Tool feature. MacroTools have icons, may be placed in PipeLines, and are loaded separately from disk, just like all other Tools.


The ToolBox

Toolbox iconBars&Pipes Professional organizes the installation, usage, and removal of Tools all from one window, the ToolBox.

Open the ToolBox by double-clicking on its icon, or choosing the ToolBox command from the Windows menu. The ToolBox window displays all currently installed Tools.

Toolbox

Tool Icons

Tools appear in the ToolBox as icons. Select a Tool by clicking once on its icon. To place a copy of the Tool in a Track or ToolPad, hold down on the mouse and drag the Tool to the desired destination. This makes a copy of the Tool and places it.

NOTE-> If there are no Tools in the ToolBox, Bars&Pipes Professional can't find the Tools to load. Often this occurs with improper installation. You will need to load in the Tools one by one. Please see the section below, Installing Tools.

The Question Mark Button

The first icon in the ToolBox window, the grey box with the "?" (question mark), is not a Tool. If you click and hold the mouse button over the question mark, a pop-up menu opens containing the names of all the Tools in the ToolBox.

To select a Tool with the pop-up menu, drag the mouse pointer until the desired Tool name highlights; then release the mouse button. A copy of the Tool icon "sticks" to the mouse. You can then drag the Tool to a PipeLine or ToolPad to drop the selected Tool in it, or click anywhere else to eliminate the copy.

Tool Names

You can optionally display the Tool names to the right of each icon by selecting the Show Tool Names option in the Preferences menu of the ToolBox.


Installing Tools

The first time you run Bars&Pipes Professional, it loads a preset collection of Tools. This preset collection is a mere subset of the dozens of Tools that come with Bars&Pipes Professional. In order to access the additional Tools included with the program, you must install them.

To install a Tool, use the Install Tool command in the ToolBox menu. This command loads the Tool from disk, places it in the ToolBox and makes the Tool a permanent part of your environment. Once you've installed a Tool, Bars&Pipes Professional automatically loads the Tool every time it runs until you remove the Tool with the Remove Tool command.

Example:

  1. Open the ToolBox window, if it is not already open.
  2. Activate the ToolBox window by clicking on it.
  3. Access the ToolBox menu by holding down the right mouse button and dragging the mouse pointer to the top of the Bars&Pipes Professional screen, over the words "ToolBox". The ToolBox menu opens.
  4. Drag the mouse down over the words "Install Tool..." and then release the right mouse button. The file requester opens.
  5. If the file requester is not already in the Tools directory, find the directory where you keep your Tools.
  6. Find the Loop Tool in the Tools directory. Double-click on Loop to open it.

NOTE-> A text file called Tools is kept in the Support directory to keep Track of which Tools have been installed. Although we don't recommend it, you can edit this file in a text editor. Please see Chapter 31, Customizing Your Environment, for more information on the Support directory.

You might load a Song or MacroTool that includes Tools that are no longer installed. Bars&Pipes senses this and tries to automatically install the missing Tools. If it can't find them, it prompts with the file requester and the missing Tool name. Then, Bars&Pipes Professional actually installs the missing Tool. As a result, the process of loading a Song can actually install one or more Tools permanently in the ToolBox!


Removing Tools

If you have a Tool in your ToolBox that you never use, consider removing it. Too many Tools eat up precious memory, take extra time when loading Bars&Pipes Professional, as well as create a jungle of icons.

To remove a Tool, first select it in the ToolBox. Then, select the Remove Tool command in the ToolBox menu. This removes the Tool and tells Bars&Pipes Professional not to automatically load the Tool every time it runs.

NOTE-> If the Tool is in a Track, ToolPad, or ToolTray, Bars&Pipes Professional alerts you that the Tool is in use, and asks you to verify the operation.

The Remove Tool option does not erase the Tool from your disk. It only removes the Tool's name out of the active Tool list, stored in the file "Tools" in the Support directory.


Creating, Editing & Saving MacroTools

Three additional commands in the ToolBox menu control the design and updating of MacroTools.

To create a new, empty MacroTool, select the command Create MacroTool. This creates a blank MacroTool and opens the Create-A- Tool window to edit it. Please see Chapter 24, Create-A-Tool, for more information.

NOTE-> You can Install and remove Macro Tools as you would any Tool.

If you'd like to make changes to an existing MacroTool, click once on the MacroTool to select it, then choose the Edit MacroTool command in the ToolBox menu, or double-click on the MacroTool. The Edit MacroTool command opens the Create-A-Tool window, so that you can make design changes.

Although the Create-A-Tool window automatically prompts you to save the MacroTool, you can also do so directly by selecting the Save MacroTool command found in the ToolBox menu. This opens the file requester, where you may choose a destination file.

NOTE-> Saving a Macro Tool to a new location updates the Installation information in the Tools file. Bars&Pipes Professional will always load the Macro Tool from the new file location instead of the old.


Using Tools in the PipeLine

Tools are most often used in the PipeLine and ToolPad. In the PipeLine, a Tool processes music flowing through it. In the ToolPad, a Tool modifies entire segments of music all at once, using the Toolize command found in the Edit and Tracks menus.

A Tool in a particular Track's PipeLine modifies the MIDI data that flows through it. Most Tools may be placed in either the Input PipeLine or the Output PipeLine. Some Tools are Input Tools, and only place themselves as the first Tool on the Input PipeLine. Other Tools are Output Tools, and only place themselves as the last Tool on the Output PipeLine.

Bars&Pipes Professional displays the complete PipeLines with all Tools only in the Tracks window, although it does display the final Output Tools in the Media Madness window as well.

Placing A Tool In A Pipeline

To place a Tool in a PipeLine, drag a copy of the Tool from the ToolBox, another PipeLine, or a ToolTray (more on that later,) and drop it into the PipeLine.

Opening The Tool's Control Window

Double-click on a Tool in a PipeLine to open its Control window. Alternatively, highlight the Tool by single-clicking on it, and choose Edit from the Tool menu. You can edit the Tool's Control window while Bars&Pipes Professional plays and MIDI events flow through the Tool. As a result, you hear instant feedback as you make changes in the Control window. You can also open multiple Control windows at once.

QuickPatch windows

Duplicating A Tool

You can duplicate an existing Tool in the PipeLine by clicking on the Tool and dragging it to a new location. Copying a Tool in this manner is useful because you can edit one Tool's Control window, then place duplicates in several other Tracks.

Moving A Tool In The PipeLine

To move a Tool in the PipeLine, click on the Tool once to highlight it, then choose the Move Left and Move Right commands in the Tools menu. Alternatively, you can use the left and right arrow keys on the Amiga keyboard to move the highlighted Tool. You can even make a Tool jump across from the Input PipeLine to the Output PipeLine and vice versa. You cannot, however, move Input and Output Tools.

NOTE-> Remember, clicking on and dragging a Tool duplicates it, rather than moving it. Also, moving a Tool from the Input PipeLine to the Output PipeLine or vice versa breaks its connections with other Tools.

Connecting With Vertical Pipes

You can actually connect a Tool in one Track to Tool in another via vertical pipes. To do so, you need two types of Tools: The first type, the branching Tool, uses preset criteria to send MIDI events to another Track. There are many branching Tools. For example, the Keyboard Splitter Tool sends all notes below its split point to a second Track and the CounterPoint Tool can send the countermelody to a second Track.

The second type of Tool, the merging Tool, sits in the second Track's PipeLine and receives incoming MIDI events. Unlike the branching Tools, there is only one merging Tool included with Bars&Pipes Professional, the Merge In Tool.

NOTE-> The Pro Studio and Creativity Add-On Kits include merging Tools that use MIDI events coming down the vertical pipes to control events in the second Track's PipeLine.

To connect a branching (sending) Tool to the merging (receiving) Tool, click on the branching Tool. Then select the Connect command in the Tools menu and click once on the merging Tool. A vertical pipe will be drawn between the two Tools, indicating that they are connected.

Pipes in Tracks 1-3

Removing A Tool

To remove a Tool from the PipeLine, highlight that Tool by clicking on it. Then select Remove from the Tool menu to remove the Tool. Alternatively, you can use the Del key on the Amiga keyboard.


Using Tools in the ToolPad

The ToolPad provides a means to permanently change your music. Whereas Tools in PipeLines process events as the events flow through them, Tools in the ToolPad do nothing until you use the Toolize command. Using the Toolize command causes the entire Song, individual Tracks, or parts thereof, to change permanently.

You'll find ToolPads in the Tracks window, the Edit and List Edit windows, the Media Madness window, and the Song Construction window. These buttons all represent the same ToolPad, regardless of which window they appear in.

The ToolPad

Unlike Tools in the PipeLine, Tools placed in the ToolPad do not process notes as they are played. Instead, they process all of the notes in a Song, sequence, or section. For example, if you place the Quantize Tool in the ToolPad, you can use it to Quantize all of the notes in a selected Track. The ToolPad holds up to sixteen Tools at once.

Placing A Tool In The Toolpad

To place a Tool in the ToolPad, click and drag it from the ToolBox, a ToolTray, or even a Track's PipeLine, and drop it onto the ToolPad. If the ToolPad is not full, the new Tool takes the next empty slot. However, if the ToolPad is full, the new Tool replaces the currently displayed Tool in the ToolPad.

NOTE-> You can put more than one of the same type of Tool in the ToolPad.

Selecting A Tool From The Toolpad

To select a Tool from the ToolPad, click down on the pad with the mouse and hold it. Under the mouse, a pop-up menu appears with sixteen Tools displayed. (The unfilled slots are displayed as empty pipes.) Move the mouse pointer to the Tool you need and lift up. The ToolPad now displays that Tool.

Editing A Tool In The ToolPad

To edit a Tool in the ToolPad, called a PadTool, first select it, then use the Edit PadTool Controls command in the Windows menu.

* TIP * You can also hold down the Shift key on your Amiga keyboard while dlcklng on the ToolPad.

This opens the Control window for the Tool, if one exists. Some Tools do not have parameters to change and therefore no Control window. You can keep the Control window open for the Tool as you use it to process your Song. You can even have several Tools' Control windows open at the same time.

Removing A Tool From The ToolPad

There is no need to remove a Tool from the ToolPad. Once the ToolPad is full, placing a Tool in the ToolPad replaces the currently showing Tool.

Toolizing With The ToolPad

Tools placed in the ToolPad can process all of the notes in an area of your Song. To do so, use the Toolize command, found in both the Edit and Track/Group menus.

The Toolize command in the Edit menu processes all notes on all Tracks between the Edit Flags. Set the Edit Flags (the two purple triangles) either by dragging them in the Tracks window or typing in positions in the Set Flags window.

Set Flags window

For more information on editing with the Edit Flags, please see Chapter 20, Multi-Track Editing.

The Toolize command in the Track/Group menu processes all notes in the currently selected Track or a Group of Tracks.

* TIP * Use the Output PipeLine to test a Tool while changing its controls. Once you're pleased with the results, drag the Tool into the ToolPad and Toollze the entire Track to make the changes permanent. Then, delete the Tool from the PipeLine since it no longer is needed.

Replacing A Tool In The ToolPad

To replace a Tool in the ToolPad with another Tool, select the Tool to discard by choosing it from the pop-up menu so that it appears in the ToolPad on the screen. Then drag the new Tool from the ToolBox onto the ToolPad. The new Tool replaces the displayed one.


ToolTrays

The ToolBox organizes the original copies of each Tool. Every time you drag a Tool from the ToolBox and place it in a PipeLine, you must double-click on the Tool and edit its Control window. In other words, while a Tool resides in the ToolBox, it cannot be edited.

On the other hand, ToolTrays provide a place to keep preset versions of Tools. Just drag a Tool from the ToolBox into a ToolTray and then edit the Tool's Control window by double-clicking on the Tool in the ToolTray.

From then on, drag the Tool from the ToolTray instead of from the ToolBox, and the changes you made remain intact. You can organize up to sixteen individual copies of Tools in each of eight ToolTray windows.

To access a ToolTray, choose one of the ToolTrays in the Tool menu. If the ToolBox window is active, you can also select a ToolTray from the ToolTrays menu. The ToolTray window opens.

ToolTray 1

Drag a Tool from the ToolBox or from a PipeLine and drop it into the ToolTray beneath the horizontal gray line. The name of the Tool appears above the gray line.

Modify the name of the Tool by clicking on its name and using the Amiga keyboard.

NOTE-> Changing the name of the Tool in the ToolTray does not change the name of the Tool in the PipeLine or ToolBox. This feature allows you to keep several copies of the same Tool in a ToolTray, and be able to distinguish between them when you dick on them.

For example, you might prepare two versions of the Quantize Tool with different resolutions and give each a name that describes its resolution.

Double-click on a Tool in a ToolTray to open that Tool's Control window. Set the parameters to whatever you want. When you drag this Tool into a PipeLine or ToolPad, it retains these parameters.

NOTE-> The ToolTrays load and save with your composition.

For a complete explanation on using ToolTrays, please see Chapter 25, ToolTrays.


Examples

In the following sections, we present some step by step examples of using specific Tools. This will help you to understand the Tool concept, and how to use Tools in your own compositions.

Let's look first at a very simple Tool called the CounterPoint Tool. Open your ToolBox. If you do not see the CounterPoint Tool, install it.

NOTE-> There are several ways to view Tools by name: You can dick on the ? button to access a scrolling list of Tools, You can dick on a Tool and view its name in the ToolBox window's Title bar. You can also select the Display Tool Names option in the ToolBox window's Preferences menu to display the Tools by name as well as Icon.

The CounterPoint Tool does not have a Control window.

Using CounterPoint On The Input Pipeline

Grab the CounterPoint Tool from the ToolBox by clicking on it with the left mouse button. Drag the Tool until it is over the Input PipeLine of Track 1, just to the right of the MIDI In Tool. Release the mouse button. Activate the Input Selector for Track 1.

Track 1 Input with the Counterpoint Tool

Play a few notes on your keyboard. You'll hear an accompaniment to the notes you play

Here's how it works: The notes you play on your keyboard come into the active MIDI In Tool. Then, the notes flow into the CounterPoint Tool. The CounterPoint Tool creates a countermelody note for each note that enters it.

The original note and the countermelody note flow down the rest of the Input PipeLine and into the Sequencer. Even if Track 1 is in record mode, since we haven't activated the Sequencer Record mode, the notes just travel right on through the Sequencer .

When the notes reach the Thru/Mute/Play faucet, they continue through if it is in Thru mode. Thru mode is represented by a blue faucet with two inputs on the left side.

NOTE-> If the faucet is red, without an Input on the left side, it is in Mute mode. Nothing will play out of the Track when the faucet is in Mute mode. If the faucet is yellow, with one Input on the left side, it is in Play Only mode. In Play Only mode, only notes previously recorded into the Track go through.

The notes flow down the Output PipeLine until they reach the MIDI Out Tool. The MIDI Out Tool sends the notes out the MIDI out port on your interface, on the MIDI channel selected by the MIDI channel selector. The MIDI channel selector is the blue number on the right of each Track.

Sending The Countermelody To Another Track

Now, lets record the original melody on Track 1, and the countermelody created by the CounterPoint Tool on Track 3. We can do this because the CounterPoint Tool is a Branching Tool. To use any branching Tool, you'll need the Merge Tool.

Select the Merge Tool from the ToolBox. Its icon is a horizontal length of pipe with an angled pipe entering it from the top left. If you don't see the Merge Tool, load it in. Place the Merge Tool on the Input PipeLine of Track 3.

Click on the CounterPoint Tool with the mouse. A red box surrounds it to show that it is the active Tool. Select Connect from the Tool menu, then click on the Merge Tool. Bars&Pipes Professional connects the CounterPoint Tool to the Merge Tool with a vertical piece of pipe. Now the countermelody flows down the vertical pipe and into the second Track.

Tracks 1-3 Inputs with Piped Counterpoint

With the Input Arrow on Track 1 still active, click on the blue 'P' in Track 3 until it turns into a red 'R'. The red 'R' should already be showing in Track 1.

Now, record another melody. When you stop the Transport, notes in Track 1 and in Track 3 are displayed. Track 1 contains the original melody, while Track 3 contains the counter melody.

Using CounterPoint On The Output Pipeline

Now that you have two Tracks containing a melody and a countermelody, let's see what happens when we place a CounterPoint Tool on the Output PipeLine of both Tracks.

You don't need to open the ToolBox to get another copy of the CounterPoint Tool. Just grab the one that is on the Input PipeLine of Track 1. Place copies of the CounterPoint Tool on the Output PipeLines of Tracks 1 and 3.

Output PipeLine with Counterpoints

Press Start on the Transport Controls to listen to the effects of these Tools. You should hear four notes simultaneously: two out MIDI channel 1 and two out MIDI channel 3.

Toolizing With CounterPoint

Pick up another copy of the CounterPoint Tool and drop it into the ToolPad. The ToolPad is the box in the upper left corner of the Tracks window, to the right of the Solo button, and to the left of the Group buttons numbered 1 through 8.

Click on Track 1, then select Toolize from the Track menu. Notice that it instantly doubles all of the notes in Track 1, adding the countermelody to the recorded music. Press Start on the Transport to hear the results.

Other Examples

You'll find more Tool examples in the Tools chapter. Learning how to use Tools can be a daunting task. Take it slow and learn one Tool at a time. Try every Tool that you can in as many ways as possible. Experience is the best teacher.

Have fun and experiment! Remember, you can always leave a Tool's Control window open while you experiment with it. In particular, this is very useful for setting up a Tool while music flows through it in the PipeLine.

Once you've learned all of the Tools that come with the basic Bars&Pipes Professional package, remember that we continue to release new Add-On Tool Kits. Call or write to us for more information.