NOTE EDITING

Chapter 8


Overview

Bars&Pipes Professional's Graphic Editor lets fine-tune your composition. All of its buttons, menu options and features eliminate guess work. In fact, the Graphic Editor has so many features that we've divided our discussion of it into several chapters. This chapter covers specifically note entry and editing.

Sequenced Notes

Before we delve into editing notes with Bars&Pipes Professional, let's look at how Bars&Pipes Professional actually represents those notes.

Sequenced notes are comprised of MIDI note on and note off events that you've input. The MIDI standard allows for a total of 128 different note values, beginning with the note C0 (C, octave 0) denoted by the byte 0, and ending with the note Gl0 (G, octave 10,) denoted by the byte 127.

NOTE-> Some synthesizers refer to the range as C-2 through G8.

Bars&Pipes Professional stores a note as a MIDI note pitch number, a starting time, and a duration. To reproduce a stored note, the Sequencer sends out the MIDI note on event at the starting time, waits for the duration, and then sends out the MIDI note off event for that note.

NOTE-> In the Multi-Media portions of this manual, you will see references to items called hit lists. A member of a hit list is actually a note in disguise. While using hit lists, instead of note number representing a note, the note number represents a command. When a Multi-Media Tool receives this command, it performs whatever task you've programmed it to perform. You'll learn more about this in Chapter 28, Media Madness.

Opening The Graphic Editor

To Open the Graphic Editor, double-click on the Track you'd like to edit, or select the desired Track and press Return. The Graphic Editor window opens, and displays the Track.

NOTE-> The Graphic Editor window is also referred to as the Edit window.

The Sequence Display

The Sequence Display occupies most of the Edit window. It shows your Sequence from left to right.

Graphic Editor window

Vertical lines, indicating the beats and measures, provide you with a view of the exact time and place of each note.

SMPTE Time

SMPTE buttonClick on the SMPTE button, located on the far right end of the Graphic Editor's command button to view the Sequence Display in SMPTE time rather than in measures and beats. This option is very useful if you're working on a project where you need to know when particular events happen in absolute minutes and seconds instead of music time.

Sizing The Display

The Sizing... option in the Display Options menu gives you five choices for displaying data: Very Large, Large, Normal, Small and Very Small. If you choose Very Large, you can do very fine work with the timing of your notes. On the other hand, the lowest resolution, Very Small, is the same as the resolution in the Main Screen. At this resolution, you gain a much better feel for how your Song progresses.

Zoom buttonsYou can also use the Zoom In and Zoom Out buttons to enlarge or reduce the display size. Click the Zoom In button to select the next larger size, up to Very Large. Click the Zoom Out button to select the next smaller size, down to Very Small.

NOTE-> The sizing of a Track determines how many measures across will be printed when printing notation.

The Show Menu

From the Edit window, use the Show menu to determine what options Bars&Pipes Professional draws in the Sequence Display. By default, Bars&Pipes Professional displays the Hybrid Staff, Piano Roll and Velocity Curve, the options most frequently used. You can toggle as many options as you want at once by holding down the right mouse button and clicking the left mouse button over the items you want to toggle.


The Staff - Hybrid

Displaying The Hybrid Staff

When you select Staff-Hybrid from the Show menu, Bars&Pipes Professional displays notes as horizontal bars on a traditional treble and bass clef. The length of the bar reflects the length of each note. Bars&Pipes Professional marks accidentals with sharps and flats. If you haven't defined a key, the Staff defaults to the key of C MAJOR.

If you select the Hit List option in the Display menu, all notes that have hit translations assigned to them display the name of the hit (for example, "Dog Bark" or "Door Slam") instead of the note rectangle. Hit List Translations are used primarily by the Media Madness Tools and the List Editor. We'll talk about Hit Lists extensively in later chapters.

Centering The Hybrid Staff

The center of the Staff - Hybrid defaults to middle C, octave five on the MIDI keyboard. To change to another octave, use the Note Range... Staff Center command in the Display Options menu. The Staff Center requester opens.

Staff Center window

In the box to the right of "Center", the requester displays the note currently at the center of the Staff. By default, the Staff centers around C5, the note C of the fifth octave.

To change the octave, click on the center note and hold the mouse down. Under the mouse, a pop-up menu appears with a choice of octaves. Move the mouse to the one you want and lift up. The center note changes to C of the octave you choose.

The Auto Center button automatically calculates the center note and accommodates the range of notes displayed.

When you finish, press Okay, to accept the new Staff Center, or Cancel, to leave it as it was.


The Piano Roll

Displaying The Piano Roll

When you select the Piano Roll, Bars&Pipes Professional displays your MIDI note events as horizontal bars on a graph which extends from a column of piano keys on the left. Like the Hybrid Staff, notes are blue.

Piano Roll

If you select the Background... Key option in the Display Options menu, the spaces on the graph that make up the current key are displayed behind the notes in a faded purple color. To learn how to set the key, please see the chapter on Song Parameters.

Like the Hybrid Staff, you can also display notes as Hits by selecting the Hit List option in the Display menu.

Changing The Piano Roll Bounds

At times, the Piano Roll may display too much or too little of your composition. A Note Event can span a range of 128 notes, just over ten octaves. The Piano Roll can show all or any section of that ten-octave keyboard. Since an individual Sequence rarely ranges more than two octaves, Bars&Pipes Professional shows two octaves by default.

To change the range of notes displayed, select the Piano Roll Bounds command, which opens the Piano Range requester.

Piano Range window

You can set two variables: the Upper Range and the Lower Range. Respectively, these denote the highest and lowest keys displayed on the Piano Roll. The Piano Roll will not display notes above the Upper Range nor below the Lower Range.

Define each boundary by the specific note and octave. To select the note, click on the note letter, in this example, C. A pop-up menu of a piano keyboard appears under the mouse. Drag the mouse to the note of choice and lift up. To set the octave, click on the octave number, in this case, 4, and a pop-up menu of octave choices appears under the mouse. Select the octave and lift up on the mouse.

The Auto Range button automatically sets the upper and lower boundaries of your sequence. To accept the new Piano Roll bounds, click on Okay. To return to the Graphic Editor window without any changes, select Cancel.


The Velocity Curve

When you select the Velocity Curve, Bars&Pipes Professional draws the velocity of each note as a vertical line. The greater the velocity, the higher the line. Since most synthesizers translate velocity directly to loudness, consider the velocity curve as a volume curve.

If your keyboard supports velocity, then the harder you strike the keys, the louder the instrument plays.

NOTE-> A number of drum machines and synthesizers that don't respond to velocity when you play them directly nevertheless respond to velocity when they receive the notes from Bars&Pipes Professional.


Staff - Notation

When you select Staff-Notation from the Show menu, Bars&Pipes Professional displays the notes on a traditional treble and bass clef in standard musical format. Please refer to the section on Notation later in this chapter for more information about transcribing music to standard notation.


Tablature

When you select Tablature from the Show menu, Bars&Pipes Professional displays note pitches as fret numbers on guitar strings. The open string note value of each string, which can be changed, is shown on the left. For more information about transcribing to tablature, please refer to the Tablature section later in this chapter.


Editing Notes with the Mouse

Across the top of the Graphic Editor window sits a row of buttons. Think of these as a palette of options. By clicking on these, you select the manner in which you use the mouse to draw, erase, drag, and alter your music.

The buttons belong to three groups: the first nine buttons from the left, the Command buttons, determine how you use the mouse. The middle four buttons, the Default Note buttons, define the current note resolution for entering and editing. On the right lie the Zoom and Speaker buttons. Use the Zoom buttons to change the range of the display. Click on the Speaker button to hear the displayed section of music.

The Command Buttons

The first nine buttons from the left are the Command Buttons. As you click each one with the mouse, the mouse's icon changes. Most of these buttons have keyboard equivalents as well. Set the Command Buttons to determine how you use the mouse. The following list describes each button briefly.

Command buttons

From left to right, the buttons are as follows:

  1. The Magnifying Glass displays information about notes you touch with the mouse.
  2. The Pencil enters notes into either Staff, Tablature, or the Piano Roll.
  3. The Magic Wand alters the length and velocity of notes in the Staves or Piano Roll; it alters the fret number of a note in Tablature.
  4. The Hand grabs and drags notes.
  5. The Duplicator makes an exact copy of the selected note and drags the copy to a new position.
  6. The Eraser deletes notes.
  7. The ToolPad contains selected Tools and processes notes with the currently-displayed Tool.
  8. The Bounding Box, working in conjunction with the Drag, Duplicator, Erase, and ToolPad buttons, enables you to draw a rectangle around a set of notes and then Drag, Duplicate, Erase, or Toolize them. The Bounding Box, working in conjunction with the Magic Wand, allows you to tie notes together.
  9. The Step Entry Button enables step entry of notes from a MIDI keyboard. This button enables you to enter notes and their durations at your own pace, without having to play your instrument keyboard in real-time.

Setting The Default Note

Before drawing, dragging, or step-entering notes, you must set the Default Note. The Default Note consists of a note value (eighth, quarter, etc.), a modifier (triplet, dotted, normal), an articulation (staccato, legato, etc.), and a dynamic level (pp through ff).

The middle group of four buttons sets these values. Upon being pressed with the mouse, each button reveals a pop-up menu with the options displayed. Drag the mouse to the desired option and lift up to select it. Bars&Pipes Professional displays your choice on the appropriate button.

Note options

From left to right, the buttons are as follows:

  1. The Default Note Value and Default Note Modifier buttons determine the type of note to be entered by the Pencil or Step entry. It also determines the interval for dragging a note left or right, in conjunction with the Lock to Default Note option in the Prefs menu.
  2. The Default Articulation button determines the length of the newly entered note.
  3. The Default Velocity button determines the emphasis, or loudness, of the newly entered note.

NOTE-> You can use the F7 through F10 keys to change these values. Use the shift key In conjunction with the function key to change them in the opposite direction.

Entering Notes With The Pencil

Pencil buttonActivate the Pencil by clicking on the Pencil Button or pressing function key "F1". Then, click the Pencil on the display to enter notes in the sequence.

NOTE-> Remember, the articulation (length) and dynamics (velocity) of the note you enter are defined by the Default Note.

Once you click down in the display, the way that the Pencil operates is determined by the following options in the Prefs menu:

Entering Notes In Staves

To enter a note in a stave, click with the Pencil. To add a sharp or flat, press once on the up or down arrow keys.

NOTE-> Whether the note displays as a sharp of flat is determined by the Key Signature. Please see Chapter 10, Editing Song Parameters, to learn how to set the Key Signature.

Entering Notes In The Piano Roll

Use the Pencil to enter notes within the range of the Piano Roll. To change the range, go to the Note Range... command in the Display Options menu.

Entering Notes In Tablature

Choose a string and click down on it with the mouse. A fret number appears corresponding to the current position defined in the Position option in the Tablature menu. Slide the mouse up and down to change the fret number, and therefore, the pitch. Please see the Tablature section, later in this chapter, for more information.


Entering Notes with Step Entry

Use the Step Entry option to enter notes directly into the Graphic Editor from your MIDI keyboard. With Step Entry, you can record at your own pace without having to play your MIDI keyboard in real-time.

Activating Step Entry

Step Entry buttonTo activate Step Entry, click on the Step Entry button. The mouse icon becomes a picture of a person's leg on a step. Then, position the left Edit Flag (the leftmost purple triangle above the display) in the location that you would like to begin step entry.

Important Points

Before Step-Entering, remember the following:

Step-Entering A Note

To Step-Enter single notes, play them one by one. After you lift up on each one, the cursor moves forward. To enter a chord, hold down each member note, lifting them all up at once. When you release all notes, the left Edit Flag moves to the right, allowing you to immediately enter another note or chord.

Step-Entering A Rest

To enter a rest, press the Space Bar. The rest will be the same duration as a note.

Backing Up And Erasing Mistakes

To back up a step, and erase a mistake, press the Backspace key.


Refreshing the Display

To refresh the display at any time while editing, press the Return key on your Amiga keyboard. If you have selected "Auto Redraw" from the Prefs menu, the display refreshes automatically and you do not have to press the Return key.


Boxing Notes

Bounding Box buttonSeveral of the Command buttons can be selected in conjunction with the Bounding Box button (F6 key). The Bounding Box lets you draw a box around a group of notes, then edit them all at once.

To draw the box, click down where you'd like one corner of the box to be and drag the mouse to the opposite corner. A box grows as your mouse travels. The box never crosses the boundary between two display strips, for example the Piano Roll and either Staff.

Once you have enclosed what you want in the box, lift up on the mouse.

The beginning of a note must be within the box to be counted as being a member. If only the later half of a note is in the box, it will not be one of the boxed notes.

The Bounding Box works in conjunction with the Magic Wand, the Eraser, the Duplicator, and the Toolizer. As we discuss each of these in the pages to follow, we'll describe how to use the Bounding Box in each case.


Altering Note Lengths and Velocities

Magic Wan buttonOnce you enter Notes, you may need to edit them by changing their lengths and velocities. To the right of the Pencil sits the Magic Wand. Select this button to alter the data with the mouse, either by clicking on it or by pressing function key "F2".

NOTE-> The Magic Wand, in conjunctlon with the bounding box, allows you to tie notes of the same pitch together. Please see Tying Notes, below.

Altering Notes In The Hybrid Staff And Piano Roll

Use the Magic Wand to alter the length of individual notes. Click down with the mouse over a note; the Editor highlights the note in red. Drag to the left to make the note shorter or to the right to make the note longer .

If the Lock Wand to Note option in the Prefs menu is enabled, the Wand sticks to the first note you select. No matter where you drag the mouse, it continually lengthens or shortens the note length. This is great if you want to edit just one note because the mouse never slips off the note.

If you want to change the lengths of more than one note at a time, deselect the Lock Wand to Note option in the Prefs menu. Edit the first note in the "stack", then drag the mouse vertically through the remaining notes. All remaining notes conform to the size of the first one you edited.

* TIP * You can also use the Left and Right Arrow keys to decrease and increase, respectively, a note's length.

Altering Notes In The Notation Staff

Use the Magic Wand to conform notes to the current Default Note. Click on any note; the Editor automatically changes the note length to that of the Default Note.

Altering Notes In Tablature

You cannot use the Magic Wand to alter the length of a note in Tablature. Instead, use one of the Staves or Piano Roll, or utilize the Magnifying Glass.

Rather than altering the length of a note, the Magic Wand alters the fret number of a selected note in Tablature. Click on the note with the Wand, and slide the mouse up and down to the desired fret number.

Altering The Velocity Curve

Drag the Magic Wand over the Velocity lines to change them. This way, you can change their individual volume levels. As an option, use the Up and Down Arrow keys to increase and decrease a note's velocity.


Tying Notes

Graphic Window edit buttons

You can tie notes of equal pitch together by using the Magic Wand in conjunction with the Bounding Box. Activate the Magic Wand and Bounding Box buttons. Surround the notes you want to tie with the Bounding Box. This ties all notes inside the bounding box that are of equal pitch together and leaves all other notes alone.


Dragging Notes

Hand button

When you select the Hand button, either with the mouse or function key "F3", the mouse icon becomes a hand with one finger extending. Use this to drag and reposition notes.

Dragged notes are affected by the following options in the Prefs menu:

Dragging Notes In A Staff Or The Piano Roll

Dragging notes right and left moves them forward and back in time. Dragging them up and down changes their position on either Staff or the Piano Roll, thereby changing their pitch.

If you have the Play Notes option in the Prefs menu selected, Bars&Pipes Professional plays each note as you drag it.

If you hold down the shift key prior to clicking on the note, the hand only moves vertically or horizontally, but not both, depending on your first move. In other words, if you hold the shift key down, click on the note, and start to drag it up in pitch, the note locks in time and only lets you change its pitch no matter how far to the left or right you drag the mouse. Likewise, if you start by dragging left or right, the note only moves in time, it does not let you change its pitch.

Dragging Notes In Tablature

Dragging notes up and down in Tablature, across strings, causes the note to jump from one string to another. The pitch of the note remains the same, while the fret number changes.

To change the note pitch, use the Magic Wand. This changes the fret number on the string, thereby increasing or decreasing the pitch.

Using Hot Keys For Dragging

You may also use the arrow keys on the Amiga keyboard to move a note. First, highlight the note that you want to change. Then, use the left and right arrow keys to shift the note backward and forward in time by the default note amount. Or, use the up and down arrows on the Amiga keyboard to change note pitch chromatically. The up arrow increases the pitch by one half step. The down arrow decreases the pitch by one half step. This is a great way to add sharps or flats to notes.

NOTE-> In the key of C Major, and all key signatures that have sharps in the key signature, notes may only be sharpened. For instance, the note F# may not be displayed as a Gb. In key signatures that have flats, notes may only be flatted. For instance, the note Gb may not be displayed as F#. Double sharps and flats are not supported.

When you use the Shift key in conjunction with the up and down arrow keys, the note shifts its pitch by an additional octave.

Dragging With The Bounding Box

You can use the Hand and Bounding Box together to move a group of notes simultaneously. First, use the mouse to draw a box around the group of notes you want to move. Then, click down in the box and drag it.


Duplicating Notes

Duplicator ButtonTo duplicate notes, click on the Duplicator button or press function key "F4". When you click and drag a note, Bars&Pipes Professional creates a new note of the same type, which you may then drag to a new destination. Once it is dragging the note, the Duplicator behaves identically to the Hand as described above.

You can use the Duplicator in conjunction with the Bounding Box to duplicate a group of notes simultaneously and drag them to a new location.


Erasing Notes

Erase buttonTo use the mouse to erase Notes, choose the Erase button, either by clicking on this button or pressing "F5". In selecting this button, the mouse icon becomes a Pencil with the Eraser end pointing down and to the left. To delete notes, click down and drag the Eraser over the Notes. You do not need to click down on each note individually. Instead, click down and drag the mouse through the notes, erasing them all at once, much like an Eraser on a chalkboard.

* TIP * Use the Eraser and the Bounding Box to erase a group of notes simultaneously.


Toolizing Notes

ToolPadThe Graphic Editor Window contains a ToolPad. In it, you place Tools, which then can process, or Toolize, your music. The ToolPad holds up to sixteen Tools. This ToolPad contains a set of Tools identical to that in the Tracks window ToolPad. In fact, all of Bars&Pipes Professional's ToolPads, including those in other Graphic Editor Windows, share the same Tools

Placing A Tool In The ToolPad

To place a Tool in the ToolPad, dragit from the ToolBox, a ToolTray, or even a PipeLine, to the ToolPad. You can place Branching, Merge, and other pipe routing Tools in the ToolPad, but they have no effect on your music. If sixteen Tools occupy the ToolPad already, the new Tool replaces the currently displayed one.

Selecting A Tool From The ToolPad

Select the Toolize button by clicking on it once. The mouse becomes a wrench with a note in its mouth.

To select a Tool in the ToolPad, click on the ToolPad a second time, while holding the mouse down. A menu of sixteen Tools appears under the mouse. Select the one you want by moving the pointer to it and lifting up.

Editing A Tool In The ToolPad

To edit the parameters of the Tool currently displayed in the ToolPad, select Edit PadTool Controls... from the Display Options Window or press down the SHIFT key and click on the ToolPad.

The Control window for the selected Tool opens, if such a window exists. There you can set the variables determining the Tool's behavior. It isn't necessary to close a Control window before using the Tool. You can continue to make adjustments while you use the Tool.

Using The Tool

Tools work in three ways in the Graphic Editor. They process all notes between the Edit Flags; they process all notes within the Bounding Box; or they effect individual notes.

Once you select the ToolPad, the Tool processes any notes you touch with the wrench. Just drag the wrench through the notes to affect them immediately.

Although Toolizing individual notes may appear somewhat peculiar at first, it's an extremely useful feature. Tools can quantize, transpose, modulate, filter, echo, invert, and do much more on a note-by-note basis.

To process all notes between the Edit Flags, first drag them to border the range of notes you'd like to Toolize. Then, select the Toolize or Selectively Toolize commands from the Edit menu. We'll discuss Toolizing with the Edit Flags in depth later in this chapter.

You may also use the Bounding Box to Toolize or Selectively Toolize a group of notes. Click down with the mouse and draw a box around the notes you'd like to Toolize.


Magnifying Notes

Magnifying GlassUse the Magnifying Glass to analyze and modify notes. The Magnifying Glass allows you to operate on a note's values by typing them in specifically.

When you select the Magnify button the Magnify window opens.

Magnify window

The Magnify window displays all of the properties of any note that you touch with the mouse and lets you edit them. Use the left and right arrow keys to move from note to note. Use the up and down arrow keys to move through all of the MIDI events in chronological order.

NOTE-> The Graphic Editor window must be activated in order to use the arrow keys, not the Magnification window.

The Time Field

The first field in the Magnify Window, "Time", indicates the time in measures, beats, and clocks of the note. The second field, "HMSF", indicates the time in SMPTE format (Hours, Minutes, Seconds, Frames). To change the time, click on either line with the mouse and enter a new time. Press the Return key to indicate that you've finished and the note jumps to the new time.

The Note Information Fields

Three information fields, "Note", "Velo", and "Leng", follow. The first indicates the note value as a key and octave, e.g., "A3", for A in the third octave. The second indicates the velocity , how hard you played the note. Often, this translates to note volume. The last field, "Leng", denotes the length of the note in measures, beats, and clocks.

NOTE-> Press the Return or Enter keys on your Amlga keyboard after you change a line to confirm the change.

Undoing, Updating, and Aborting

Any changes that you make while in the Graphic Editor do not take effect until you either choose the Update command from the Edit menu or close the Graphic Editor.

NOTE-> If you haven't updated the Track but you'd like to hear your edits along with the other Tracks, enable the Perform All Tracks option in the Prefs menu and dick on the Speaker button.

Of course, if you don't like your edits, you can close the Editor with no changes made to the Track by selecting the Abort command in the Edit menu.

Finally, if you make a single mistake while editing you don't necessarily want to Abort the entire editing session. Select the Undo command from the Edit menu to undo your last edit.

Here's a rundown of the Edit menu commands:

Undo (Right Amiga - U)
Use Undo in the Edit menu to return your Sequence to its state prior to the last edit operation. In addition to undoing any of the commands in the Edit menu, Undo works on all of the mouse-based editing operations, such as inserting, dragging, and altering Events.

Update (Right Amiga - Z)
Use Update in the Edit menu to update the Tracks window. In this manner, your changes are integrated into the Song without closing the window.

Abort (Right Amiga - Q)
Use Abort in the Edit menu to abort the editing process and revert your Track to its condition at the last Update (or before opening its Graphic Editor). The Graphic Editor window closes without updating the Track.


Auditioning Your Edit

In the Edit window, you have the option of hearing notes as you enter or drag them. Also, you can listen to the visible portion of your music, or listen to the portion from one Edit Flag to the other. You can hear these portions by themselves, or in context with the other Tracks you've recorded.

Hearing Notes As They Are Entered Or Dragged

If you set the Play Notes flag in the Prefs menu, every time you enter, drag, or Toolize a note, you will hear it. Bars&Pipes Professional sends the note from the Graphic Editor out through the Output side of the Track's PipeLine. If this option is not selected, the editing process is silent.

Listening To The Displayed Section

Speaker buttonTo listen to the portion of your Song displayed in the editor window, click the Speaker button. You can use the Sizing option or the Zoom In/Zoom Out buttons to control how much of your Song Bars&Pipes Professional plays.

Listening To The Portion Between The Edit Flags

Choose the Listen option in the Edit menu to play the music from the left Edit flag to the right Edit flag.

Hearing Edits In Context With Other Tracks

Choose the Perform All Tracks option in the Prefs menu. When you click on the Speaker or choose the Listen option, the Editor plays all of the Tracks along with the music in the Graphic Editor. Otherwise, if you do not select this option, the Editor plays only the notes in its window.

Performing With The Transport Controls

You can also listen to your edits in context by clicking on the Start button in the Transport Controls, starting the Sequencer. However, this plays from the Track, not the Edit buffer.

NOTE-> This provides a valuable way to compare your edits before and after. Play from the Transport Controls to hear the muslc prior to opening the Ed,t window. Enable Perform All Tracks and dick on the Speaker button to hear the music with the new edits in place.

Scrolling With The Sequencer Performance

Performance Select Scroll With Performance from the Display menu if you'd like the Sequence Display to scroll along when you play from the Transport Controls.

Viewing Your Edit With Other Tracks In The Background

You can view other Tracks in the background of the Graphic Editor's Hybrid Staff and Piano Roll displays. To do so, go to the Tracks window and create a Group composed of the Track you are editing and the Tracks you'd like to see in the background. Once the Group is active, the extra Tracks display in grey in the background of the Graphic Editor. This feature allows you to compare notes in one Track with notes in others.

NOTE-> Please see Chapter 19, Advanced Sequencing, for information on creating and using Groups.


Notation

Displaying Notation

When you select Staff-Notation from the Show menu, Bars&Pipes Professional displays the notes on a traditional treble and bass clef in standard musical format.

Notation

Bars&Pipes Professional marks accidentals, those notes which fall outside of the selected key, with sharps or flats. If you haven't defined a key, the Staff defaults to the key of C MAJOR (no standard notes sharped or flatted).

NOTE-> The Edit window refreshes after each editing operation whenever Staff-Notatlon is activated.

The Notation Resolution

When you select Staff - Notation, Bars&Pipes Professional creates rests and ties on the fly. Bars&Pipes Professional uses the duration of each note and the notation resolution to determine what the music looks like. The notation resolution is the smallest note value (eighth, sixteenth, etc.) that Bars&Pipes Professional displays.

You can control the resolution of the notation by selecting Resolution from the Notation menu.

By default, Bars&Pipes Professional selects a sixteenth note resolution. Always choose a resolution that corresponds to the shortest note in the Track. Otherwise, Bars&Pipes Professional displays the note at the selected resolution, which means that shorter notes may run together. On the other hand, if you set the resolution too small, Bars&Pipes Professional can add unnecessary fractions of notes that muddle the page.

NOTE-> Bars&Pipes Professional plays the notes as you have composed them, even if the selected Resolution causes them to display improperly.

Notation Transposition

Bars&Pipes Professional supports two different key types: Concert Key and Transposed Key. Transposed Key applies to those instruments that require transposition, e.g., Eb Alto Sax or Bb Clarinet. If you select a Transposed Key for a particular Track, you have the option of displaying it either in Concert Key or Transposed Key.

To assign a Transposed Key to a Track, select Transposition... from the Notation menu. This opens the Transposition requester.

Transposition window

Most of the time, you'll be using the Transposition Type button. When you click down on this button, Bars&Pipes Professional opens a pop-up menu containing a list of all popular instruments.

If you are writing for an instrument that is not in the list (e.g., piccolo trumpet), select Custom from the list. Then adjust the Octave and Interval sliders to the desired transposition. The Octave slider steps the transposition by octaves; the Interval slider controls the interval within an octave, e.g., a major third or minor sixth. You can also alter any of the instrument presets in the list.

To switch the display of a Track to Concert or Transposition Key, select Notation... from the Display Options menu.

Updating The Notation Display

In certain situations, typically after a lot of editing, the Notation display may contain a few errors. To refresh the Notation display, use the Update Transcription command found in the Notation menu. Bars&Pipes Professional recalculates where to place ties and rests, then redisplays the Track's Notation Staff.

Transcribing Notation

The Transcribe option in the Notation menu goes one step further than the Update command. It commands Bars&Pipes Professional to recalculate the notation values of the notes themselves. It uses the value chosen in the Resolution... option to determine the smallest note that may be displayed. It also uses the options in the Transcription Options requester to determine how it addresses various transcription issues.

You can transcribe the entire Track, or just the portion of the Track between the Edit window's Edit Flags by choosing All or Between Flags respectively. Bars&Pipes Professional then calculates the notation value for each note, and insert rests appropriately.

Transcription Options...

The Transcription Option requester controls the way Bars&Pipes Professional transcribes music. Open it by selecting the Transcription Options command in the Notation menu.

Transcription Options...

The Transcription Options requester contains three categories of buttons: Note length options, Note stem options, and Chord options.

The Note length buttons help Bars&Pipes Professional decide how to represent a note's length. The following lists each Note length option in detail:

Overlap Notes
When you select Overlap Notes, the Transcribe command handles overlapping notes by creating tied notes. Otherwise, the Transcribe command truncates the first note before starting the second. By default, Overlap Notes is off for a cleaner, though slightly less accurate, representation.

Extend Notes
When you select the Extend Notes option, the Transcribe command extends each note to the next note or beat, whichever comes first. This option makes the display cleaner because it minimizes the use of rests.

Insert Rests
When you select the Insert Rests option, the Transcribe command displays rests. Otherwise, rests will not be transcribed. By default, this option is on.

The Chord Options also control the way Bars&Pipes Professional transcribes music. Bars&Pipes Professional considers notes that begin at the same time, within the selected Resolution, to be members of the same chord. These options control how it decides to display notes in one chord.

The following Chord Options are mutually exclusive:

Shorten Notes
When you select the Insert Notes option, the Transcribe command causes all notes in a chord to be displayed as the smallest note in the chord.

Lengthen Notes
When you select the Lengthen Notes option, the Transcribe command causes all notes in a chord to be displayed as the longest note in the chord.

Keep Note Lengths
When you select the Keep Note Lengths option, the Transcribe command transcribes the notes in a chord to different lengths. It splits longer notes into tied notes.

The Note Stems options controls how Bars&Pipes Professional transcribes stem directions:

Auto Stem
The Auto Stem option lets Bars&Pipes Professional decide which directions to place the note stems.

Stem Up
The Stem Up option sets all note stems up.

Stem Down
The Stem Down option sets all notes stems down.

Oppose Rhythm
With the Oppose Rhythm option selected, Bars&Pipes Professional analyzes the music for two different rhythms in each measure. If there are two different rhythms, it sets the stems up on the first rhythm and the stems down on the second. This option is useful in conjunction with printing notation.

Printing Notation

Choose the Print... command from the Notation menu to open the Print Requester for the Track. Please see chapter 11, Printing Notation, for more information.

Centering The Notation Staff

The center of the Notation Staff defaults to middle C, octave five on the MIDI keyboard. To change to another octave, use the Note Range... Staff Center command in the Display Options menu. The Staff Center requester opens.

In the box to the right of the Center: prompt, the requester displays the note currently at the center of the Staff. By default, the Staff centers around C5, the note C of the fifth octave.

To change the octave, click on the center note and hold the mouse down. Under the mouse, a pop-up menu appears with a choice of octaves. Move the mouse to the one that you want and lift up. The center note changes to C of the octave you choose.

The Auto Center button automatically calculates the center note and accommodates the range of notes displayed.

When you finish, press Okay to accept the new Staff Center, or Cancel, to leave it as it was.

Tablature

Displaying Tablature

When you select Tablature from the Show menu, Bars&Pipes Professional displays note pitches as fret numbers on guitar strings. The open string note value of each string, which can be changed, is shown on the left. To the left of that is either an ON or an OFF. This value is used by the Tabulate... menu option in the Tablature menu. If a string is ON, it may have notes assigned to it. Otherwise, notes are not be assigned to it.

Setting The Tablature Resolution

Use the Set Tablature Resolution command to control how Bars&Pipes Professional spreads notes across the strings. This opens the Tablature Resolution requester.

Tab Resolution

Since tablature is not concerned with durations of notes, every note could potentially be transcribed to the same string (provided that the pitch of the note exists on the string).

Notes which sound simultaneously obviously need to be transcribed to different strings in order to be played simultaneously. Notes which do not sound simultaneously can be played on the same string, one after another.

The larger the Tablature Resolution, the more notes Bars&Pipes Professional attempts to transcribe simultaneously. This value is measured in clocks. When Bars&Pipes Professional transcribes one note, it goes on to the next note and the next note, filling up each of the six guitar strings.

Once Bars&Pipes Professional has looked ahead of the first note by the number of clocks set by the Tablature Resolution, Bars&Pipes Professional starts over from scratch, filling each string with a note, one by one.

You can set the Tablature Resolution from one clock to 768 clocks.

Setting The Tablature Position

Use the Set Tablature Position requester to control which position, or fret, Bars&Pipes Professional uses during transcription. This value can be set to auto, or from one to 23.

Tab Position

With auto position chosen, Bars&Pipes Professional attempts to find the most comfortable position for the notes to be played in.

When a specific position is chosen, Bars&Pipes Professional attempts to place all notes within one fret below and four frets above the selected position.

Transcribing Tablature

Use the Tabulate... command to transcribe your music to tablature. Choose All or Between Flags to transcribe all of the Track or just the portion between the Edit Flags.

Changing String Octaves

Open the Change String Octaves requester to change the octaves of all strings up or down.

Change String Octaves

This allows easier access to some transcriptions.

Enabling And Disabling Strings

Sometimes, you may want to transcribe a piece of music only to certain strings. Use the ON/OFF toggle to do so. Click with the Magic Wand on the ON/OFF to toggle between the two.

Tab

NOTE-> Even though a string may be disabled for transcription, you can still drag or Input a note by hand onto that string.

* TIP * MIDI guitarists can use this feature to get an accurate transcription of what the play. (Please see below.)

Changing Open String Notes

Click with the Magic Wand on the open string note value, and drag the mouse up and down to change the open string note value.

Creating A Note In Tablature

To create a note in tablature, click in the tab area with the Pencil. A number appears, indicating the fret number. To set the pitch to the desired note, continue by dragging the mouse up or down to change the number to the correct fret. The duration of the note created is equal to the default note value.

Editing A Note In Tablature

Only the pitch of a note can be changed in Tablature, not the duration. Use the Magic Wand to change the note pitch of existing notes. Click on the note's fret number with the Wand; then drag the mouse up and down to change the fret number. To change the duration, use the Wand in the Piano Roll or Hybrid Notation displays. To change the note velocity, use the Wand in the Velocity display.

Creating An Accurate Transcription

If you record from a MIDI guitar, Bars&Pipes Professional can create an accurate transcription of what you play. Set up Bars&Pipes Professional to record each string on a separate Track, using the multiple-in preferences option, and have your MIDI guitar output each string on a different MIDI channel.

After recording, go into each Track's Edit window. Display Tablature, and set the ON/OFF toggles for each string so that only the correct string is ON, and all others are OFF. Choose the Tabulate... option from the Tablature menu to transcribe the music to the string. This sets each Track to tabulate all of its notes on only the chosen string.

Once you've finished with all six strings, close each Edit window. Create a Group out of the six Tracks, and use the Merge option in the Group menu to merge all six Tracks into one Track. Each note retains its string identity. When you look at the Tablature for the merged Track, you will see an accurate transcription of what you've played.

NOTE-> Please see Chapter 19, Advanced Sequencing, for Information on creating and using Groups.


Cut and Paste Editing

The first menu on the left in the Graphic Editor window is the Edit menu. Most operations in this menu work on the section between the Edit flags. The Edit flags are the purple triangles above the Sequence Display.

We'll refer to the section between the Flags as the Clip. A Clip includes all Events and Parameters which occur between the two Flags. You can drag the Edit flags to any location, and then cut, copy, paste and place Clips into the Clip buffer or, if it is open, the ClipBoard.

NOTE-> The ClipBoard is explained in the Multi-Track Editing chapter.

Flags

To set an Edit Flag, click down on it and drag. If you drag beyond the edge of the display, it scrolls. The Edit Flags follow the same rules for alignment as the Flags in the Tracks window; when you lift up on the Flag, it jumps to the leftmost alignment boundary. By default, alignment is set to every measure. Change the alignment by selecting from the Align With... option in the Prefs menu. Alternatively, set the alignment with the alignment buttons in the Set Flags window.

Let's look at each edit command in the Edit menu:

Cut (Right Amiga - X)
Use the Cut command to cut a Clip from your Sequence. Doing so removes the section between the Edit Flags. Everything to the right of the section shifts to the left Edit Flag. You can then use the Paste command to insert the Clip elsewhere in your Track. If the ClipBoard window is open, the Clip displays in it. Use this if you'd like to Cut and Paste between multiple Edit windows. When the ClipBoard window is closed, the Clip remains hidden for use within the same Track.

Copy (Right Amiga - C)
Use the Copy command to copy a Clip without actually removing it. Nothing visibly happens, but the section between the Edit Flags becomes a Clip, available for Pasting. If the ClipBoard window is open, the Clip appears in it.

Paste (Right Amiga - P)
Use the Paste command to insert a Clip after the placement of the left Edit flag. If the ClipBoard window is open, the Paste command uses the currently selected Clip in the ClipBoard. Otherwise, it uses the result of the last Cut or Copy operation from the same Edit window.

You may do multiple Paste operations with the same Clip. The Clip remains the same until the next Cut or Copy command.

Mix (Right Amiga - M)
Use Mix to merge a Clip on top of a section. Starting at the left Edit Flag, Bars&Pipes Professional mixes in Events such as notes, pitch bends, and after-touches, but ignores Parameters such as Chords, Rhythms, etc. Once again, if the ClipBoard window is open, the Mix command uses the currently selected Clip in the ClipBoard. Otherwise, it uses the result of the last Cut or Copy operation from the same Edit window.

Erase (Right Amiga - E)
Use Erase to clear the section between the left and right Edit Flags. All Events disappear, which leaves your Sequence silent during this section. Erase is different from the Cut command, in that the section to the right of the Clip is not shifted over to the left Edit Flag and nothing is placed in the ClipBoard for later Paste or Mix operations.

Insert (Right Amiga - I)
Use Insert to insert a blank space in your music between the Edit Flags. This command comes in handy when adding a section somewhere in the middle of the Sequence. Insert the section, then use whatever methods you prefer to fill the gap with music.

Delete (Right Amiga - D)
To delete a section between the right and left Edit flags, use the Delete command. This command operates identically to the Cut command, but does not place the deleted section into the Clip buffer or ClipBoard.

Toolize (Right Amiga - T)
Use Toolize to process the Clip with the currently selected Tool in the ToolPad.

Selective Toolize
Use the Selective Toolize command to selectively Toolize only certain events and note ranges between the two Edit Flags. When you select this option, a requester appears.

Selective Toolize window

Highlight in red the MIDI event types you want to Toolize. If you select Note On/Off, you may select a note range with the two sliders.

Once you've set the parameters, select the Toolize button. The Tool in the ToolPad processes all activated event types and, if Note On/Off is activated, all notes between the upper and lower limits inclusive.

Repeat... (Right Amiga - R)
Use Repeat to duplicate a section of your Sequence. This command makes multiple copies of the section between the Edit Flags and inserts them into the Sequence.

When you select the Repeat command from the Edit menu, the Repeat requester opens. enter the number of repeats, then select Okay or Cancel.

Listen (Right Amiga - L)
Use Listen to preview everything in the section between the Edit Flags. Bars&Pipes Professional plays all MIDI Events in the section at the current tempo. Because the Events travel down the PipeLine, any Tools you have selected to process the Output PipeLine will process the section as it plays.

* TIP * The Listen command is different from the Speaker button because the Listen command plays back everything between the Edit Flags. The Speaker button plays back everything that is visible in the Edit window.

If the Perform All Tracks option in the Prefs menu is selected, the Listen command plays all other Tracks in the sequence as well.

Boundaries... (Right Amiga - B)
Use Boundaries to enter the numerical values for the Edit Flags. Doing so opens a requester into which you can type positions for the two Flags.